User Tools

Site Tools


eclipse_setup

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
eclipse_setup [2017/11/29 16:20]
waruna [Eclipse Setup Using Plugins]
eclipse_setup [2017/11/29 16:37] (current)
waruna [Common Pitfalls]
Line 66: Line 66:
  
 You may have some error connecting to the repository through eclipse You may have some error connecting to the repository through eclipse
 +  * When you run a *.cs file, if you see an error containing "​com.google.common"​ then try again after removing "​com.google.guava_21.0.0.v20170206-1425.jar"​ file from Eclipse/​plugins directory.
   * When your connection gets lost while trying to connect:   * When your connection gets lost while trying to connect:
      * Go to ''"​Preferences→Team→SVN"''​ and change the SVN interface to ''"​SVNKit(Pure Java)"''​ and try again.      * Go to ''"​Preferences→Team→SVN"''​ and change the SVN interface to ''"​SVNKit(Pure Java)"''​ and try again.
Line 71: Line 72:
  
 Check the following if something does not work Check the following if something does not work
-  * AlphaZ requires JRE1.7. Please make sure you have the Java installed on your machine, and it is the default java version used by eclipse. Otherwise, the plugins installed will not be activated. ​To be sure that your eclipse is using Java 7, you can start your eclipse with explicitly specified Java path. For example: ./eclipse -vm /​home/​yun/​yun_temp/​jdk1.7.0/​bin/​java .  +  * AlphaZ requires JRE1.8. Please make sure you have the Java installed on your machine, and it is the default java version used by eclipse. Otherwise, the plugins installed will not be activated. ​
-  * AlphaZ is updated frequently, if you are using it on an external machine, run the update script+
   * Most of the machines in the department is 64bit linux, but some are 32bit. You won't be able to start eclipse in those machines.   * Most of the machines in the department is 64bit linux, but some are 32bit. You won't be able to start eclipse in those machines.
-  * Eclipse ​may not reflect ​some changes try+  * If Eclipse ​does not reflect ​the changes ​you made, try
     * Cleaning the project     * Cleaning the project
     * Starting eclipse with -clean option so that plug-ins are refreshed     * Starting eclipse with -clean option so that plug-ins are refreshed
eclipse_setup.txt · Last modified: 2017/11/29 16:37 by waruna